Quorum Bills Search degradation

Incident Report for Quorum

Resolved

The issue has been resolved.
All systems are now functioning as expected and site performance has returned to normal.
Posted Aug 09, 2025 - 14:47 EDT

Monitoring

We’ve implemented a fix to address the performance issues causing bills search degradation
The site is now operating normally, but we are continuing to monitor closely to ensure stability.
Posted Aug 09, 2025 - 12:16 EDT

Investigating

We are currently experiencing issues that may impact bills-related search functionality. We’re investigating the cause and will provide an update as soon as possible.

We will send an additional update in 30 minutes.
Posted Aug 09, 2025 - 12:14 EDT
This incident affected: Quorum Platform (WebUI).