Quorum degraded performance

Incident Report for Quorum

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 12:55 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2025 - 12:35 EST

Identified

We have identified the issue and are in the process of recovering the impacted service. We’ll share another update once full functionality is restored.
Posted Nov 12, 2025 - 12:29 EST

Investigating

We are currently experiencing degraded performance on Quorum Pages. Our team is actively investigating the issue and will provide updates as soon as more information is available.
Posted Nov 12, 2025 - 12:19 EST
This incident affected: Quorum Platform (WebUI).