Outbox Disruption

Incident Report for Quorum

Resolved

The issue with Outbox has been resolved.
All affected services are now functioning as expected.
Posted Jun 09, 2025 - 17:14 EDT

Monitoring

The issue affecting Outbox has been resolved, and all systems are now operating normally.
Our team will continue to monitor the service to ensure stability.
Posted Jun 09, 2025 - 16:53 EDT

Investigating

Some users may be experiencing trouble when using Outbox. Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Jun 09, 2025 - 16:42 EDT
This incident affected: Outbox Email Delivery.