Grassroots Campaing Call a Number Failing

Incident Report for Quorum

Resolved

This incident has been resolved.
Posted May 07, 2025 - 17:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2025 - 17:04 EDT

Update

We are continuing to investigate this issue.
Posted May 07, 2025 - 16:55 EDT

Investigating

We are currently experiencing a service disruption impacting the Quorum Grassroots Campaign Type Call a Number.
Our team is actively investigating the root cause and working to implement a solution. All users and systems are currently affected.

We will share another update within the next 30 minutes.
Posted May 07, 2025 - 16:22 EDT
This incident affected: Quorum Platform (WebUI), Quorum API, Quorum PAC, Quorum Grassroots Campaigns, Outbox Email Delivery, Quorum Copilot, PAC Classic, and Client Integrations.