Quorum degraded performance

Incident Report for Quorum

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 16:42 EDT

Monitoring

Quorum experienced a period of degraded performance. The issue has been identified and resolved.
The site is now operating normally, and our team is continuing to monitor closely to ensure ongoing stability.
Posted Oct 15, 2025 - 16:07 EDT
This incident affected: Quorum Platform (WebUI).