We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 20:59 EDT
Monitoring
We’re pleased to report that AWS has restored all of its functionality following the recent service disruptions. Our monitoring indicates that all primary services are now operating normally, with significant improvements in response times and overall reliability. While systems have stabilized, our team continues to actively monitor performance to ensure ongoing stability. We sincerely appreciate your patience throughout the disruption and will continue to keep you informed of any further developments. Thank you for your continued understanding and support.
Posted Oct 20, 2025 - 20:13 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 19:16 EDT
Update
Services continue to come back online, and many are now fully operational. We’re seeing a reduction in errors and latency; however, some elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team is actively monitoring the situation as we await full recovery from our service provider.
We’ll share another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 19:15 EDT
Update
Services continue to come back online, and many are now fully operational. We’re seeing a reduction in errors and latency; however, some elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team is actively monitoring the situation as we await full recovery from our service provider.
We’ll share another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 18:00 EDT
Update
Services continue to come back online, and many are now fully operational. We’re seeing a reduction in errors and latency; however, some elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team is actively monitoring the situation as we await full recovery from our service provider.
We’ll share another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 17:17 EDT
Update
Services continue to come back online, and many are now fully operational. We’re seeing a reduction in errors and latency; however, some elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team is actively monitoring the situation as we await full recovery from our service provider.
We’ll share another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 16:56 EDT
Update
Services continue to come back online, and many are now fully operational. We’re seeing a reduction in errors and latency; however, some elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team is actively monitoring the situation as we await full recovery from our service provider.
We’ll share another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 16:24 EDT
Update
Services are beginning to come back online, and we’re seeing a reduction in errors and latency. However, elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team is actively monitoring the situation as we await full recovery from our service provider.
We’ll provide another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 15:38 EDT
Update
We’re beginning to see a reduction in errors and latency; however, elevated levels may still persist due to the ongoing AWS service disruption in the US-EAST-1 region. Our team continues to actively monitor the situation while we await full recovery from our service provider.
We’ll share another update as soon as more information becomes available. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 15:10 EDT
Update
We are still experiencing elevated error rates and latency due to the ongoing AWS service disruption in the US-EAST-1 region. Our team continues to monitor the situation closely while we wait for our service provider to complete their recovery efforts.
We’ll share another update as soon as we have more information. Thank you for your continued patience.
Posted Oct 20, 2025 - 14:31 EDT
Update
We are still experiencing elevated error rates and latency due to the ongoing AWS service disruption in the US-EAST-1 region. Our team continues to monitor the situation closely while we wait for our service provider to complete their recovery efforts.
We’ll share another update as soon as we have more information. Thank you for your continued patience.
Posted Oct 20, 2025 - 13:53 EDT
Update
We are still experiencing elevated error rates and latency due to the ongoing AWS service disruption in the US-EAST-1 region. Our team continues to monitor the situation closely while we wait for our service provider to complete their recovery efforts.
We’ll share another update as soon as we have more information. Thank you for your continued patience.
Posted Oct 20, 2025 - 13:13 EDT
Identified
We are still experiencing elevated error rates and latency due to the ongoing AWS service disruption in the US-EAST-1 region. Our team continues to monitor the situation closely while we wait for our service provider to complete their recovery efforts.
We’ll share another update as soon as we have more information. Thank you for your continued patience.
Posted Oct 20, 2025 - 12:41 EDT
Investigating
We’re currently experiencing increased error rates and latency across multiple Quorum services due to an ongoing AWS service disruption in the US-EAST-1 region.
We sincerely apologize for the delay in posting this update—our status page was also affected by the same regional AWS outage, which temporarily limited our ability to communicate in real time.
Thank you for your patience as we work through this issue. We’ll continue to provide updates here as services recover and stabilize.