PAC Service Disruption

Incident Report for Quorum

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 17:26 EDT

Monitoring

The issue affecting the PAC Platform has been resolved. Our team has restored normal service and is now monitoring the system to ensure continued stability.
Posted Oct 23, 2025 - 16:16 EDT

Investigating

We are currently experiencing a service disruption impacting the PAC Platform. Our team is actively investigating the root cause and working to implement a solution.

We will share another update within the next 30 minutes.
Posted Oct 23, 2025 - 16:01 EDT
This incident affected: Quorum PAC and PAC Classic.