Quorum degraded performance

Incident Report for Quorum

Postmortem

On October 27, 2025, Quorum experienced a period of degraded performance and intermittent downtime affecting features that rely on search — including Bills, Documents, Alerts, and Tracking Boards. The issue was identified as excessive system load caused by unusually complex search queries, which temporarily impacted the responsiveness of several parts of the platform.

Our team was automatically notified of the problem and took appropriate steps to mitigate the issue. Service availability and performance were largely restored within the hour, with full stability confirmed overnight. AI Tracking Boards were not affected, and no data loss occurred.

Following the incident, Quorum has taken near-term action to improve monitoring and runbooks to reduce the impact of future incidents impacting search systems, and is implementing additional automatic guardrails to prevent unusually complex queries from affecting system performance.

Operational excellence and customer trust are central to everything we do, and we are committed to making the necessary improvements to ensure our platform remains reliable, resilient, and responsive to our customers’ needs.

All Quorum systems are now fully operational. We appreciate your patience and continued partnership as we strengthen the performance and reliability of the Quorum platform.

Posted Oct 31, 2025 - 16:17 EDT

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 21:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 18:56 EDT

Identified

We have identified the issue and are in the process of recovering the impacted service. We’ll share another update once full functionality is restored.
Posted Oct 27, 2025 - 18:02 EDT

Investigating

We are currently experiencing degraded performance on Quorum Pages. Our team is actively investigating the issue and will provide updates as soon as more information is available.
Posted Oct 27, 2025 - 17:49 EDT
This incident affected: Quorum Platform (WebUI).