Phone2Action Campaign Degradeded Performance

Incident Report for Quorum

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 15:46 EST

Monitoring

We have implemented a fix for the issue that caused degraded performance in Phone2Action campaigns. System performance has returned to normal, and all campaign actions are now processing as expected.

Our team will continue to closely monitor the platform to ensure stability and prevent recurrence.
Posted Nov 03, 2025 - 15:26 EST

Investigating

We are currently investigating reports of degraded performance affecting Phone2Action campaign delivery and response times. Users may experience delays in sending or processing campaign actions. Our engineering team is actively working to identify the root cause and restore full functionality.
Posted Nov 03, 2025 - 15:09 EST
This incident affected: Phone2Action.