Pages may experience higher latency

Incident Report for Quorum

Resolved

All systems are now functioning as expected and site performance has returned to normal.
Posted Sep 15, 2025 - 11:45 EDT

Monitoring

The site is now operating normally, but we are continuing to monitor closely to ensure stability.
Posted Sep 15, 2025 - 11:37 EDT

Investigating

The site is currently experiencing a higher than normal latencies, and may be causing pages to be slow. We’re investigating the cause and will provide an update as soon as possible.

We will send an additional update in 30 minutes.
Posted Sep 15, 2025 - 11:37 EDT
This incident affected: Quorum Platform (WebUI).