AI Tracking Board Degraded Performance

Incident Report for Quorum

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:59 EST

Monitoring

The issue causing the degraded service for our AI Tracking Board has been resolved, and we are now actively monitoring the functionality to ensure stability.
Posted Nov 18, 2025 - 09:54 EST

Investigating

We are currently experiencing a degraded service for our AI Tracking Board functionalities. This degradation is due to an ongoing outage with our third-party service provider. Our teams are actively monitoring the provider's status and working to ensure service restoration as soon as the upstream issue is resolved.
Posted Nov 18, 2025 - 09:20 EST
This incident affected: Quorum Platform (WebUI).